foto1
Internet & Security
foto1
Learn to build your website
foto1
Try to our Goal!
foto1
Tip & Tricks to use Computer
foto1
Operating System


Our Sponsor

side 1

Easyhome Group

krumontree200x75
isangate com 200x75
ppor 200x75
isangate net 200x75

No. of Page View

blood donate

Joomla 4 01

เมื่อวานนี้ 17 สิงหาคม 2021 เป็นวันครบรอบ 16 ปีที่แล้ว เมื่ออดีตทีมพัฒนาหลักของ CMS ที่ชื่อ Mambo ได้ออกมาประกาศว่า พวกเขากำลังจะออกจาก Mambo และเริ่มต้นกับสิ่งใหม่ๆ...  ในชื่อ Joomla! แล้วก็มีชุมชนนักพัฒนาทั่วโลกเข้ามาร่วมมือกันแก้ไข เพิ่มเติมระบบต่างๆ ให้กับ Joomla! ได้แข็งแกร่งขึ้นและเป็นที่รู้จักจนถูกนำมาใช้งานกันแพร่หลายในเวอร์ชั่น Joomla 1.5 ความร่วมมือจากชุมชนหลายๆ ชาติ รวมทั้งทีมคนไทยด้วย ได้ช่วยกันสรรสร้าง Module, Component, Plugins, Template และส่วนขยายอื่นๆ เรื่อยมาเป็น Joomla 2, Joomla 3.10 เมื่อวานนี้ และพร้อมจะปล่อยเวอร์ชั่นล่าสุด Joomla 4.0 ออกมาให้ใช้งานกัน แต่เดี๋ยวก่อน...

Joomla! 4 A new world of possibilities

อย่าเพิ่งวู่วาม มีความอยากจะอัพเดทก่อนใครเขาเชียวนะ ถ้าไม่ศึกษาก่อนให้ดีจากเว็บไซต์ Joomla 4.0 ไม่ทำการสำรองข้อมูลของเว็บไซต์เดิมให้เรียบร้อยก่อน ไม่จัดการกับสิ่งต่างๆ ที่เกี่ยวข้องบนเครื่องแม่ข่าย(Server) ให้ถูกต้องเหมาะสม ท่านจะพบกับ...

Joomla 4 03

เพราะสิ่งที่ Joomla 4.0 ต้องการสำหรับการอัพเดทและติดตั้งใหม่นั้น เกินกว่าที่เราคาดคิดมากทีเดียว ขืนไม่ดูตาม้าตาเรือ พอได้ข่าวว่าถ้าอัพเดท Joomla 3.10 แล้ว จะสามารถอัพเดทเป็น Joomla 4.0 ได้นั้นมันไม่จริงทั้งหมด ต้องทำตามที่ระบบมีความต้องการขั้นต่ำที่สุดก่อน (จริงๆ แล้วควรจะสูงกว่าขั้นต่ำแหละจึงจะไปรอดนะครับ ทำงานได้ราบรื่นสมใจตามคลิปวีดิโอด้านบน) ถ้าต่ำกว่าก็มีพังตามรูปบนนี้

Joomla 4 02

นี่คือความต้องการของ Joomla 4.0 ก่อนจะทำการอัพเดท หรือติดตั้งใหม่ กรอบสีแดงคือค่าแนะนำว่าจะทำงานได้ดีราบรื่น ถ้าสูงกว่านี้ยิ่งดี ส่วนกรอบสีเขียวคือค่าต่ำสุดที่จะสามารถติดตั้งผ่านได้ การทำงานอาจจะยังมีสะดุดอยู่ครับ รูปบนที่ติดตั้งไม่ผ่านคือผมทำการอัพเดทจาก Joomla 3.10 บนเครื่องแม่ข่ายที่รัน PHP Version 7.2.3 ส่วนฐานข้อมูล MySQL กับ Apache นั้นสูงตามที่ต้องการก็ยัง Error 500 จำพวกอยู่ครับ

เราจะสามารถอัพเกรดเป็น Joomla 4.0 เมื่อ

  • เครื่องที่ให้บริการกับเรานั้นสามารถอัพเกรด PHP, MySQL, Apache หรือ Services อื่นได้ถึงกำหนดที่ระบบต้องการในกรอบสีแดงภาพบน
  • มั่นใจว่าบรรดา Module, Component, Plugins, Template ที่เราใช้อยู้ Support หรือทำการแก้ไขให้เหมาะสมกับ Joomla 4.0 แล้ว
  • โดยเฉพาะ Component, Template ดูจะเป็นปัญหาใหญ่ที่สุด หลายๆ ทีมพัฒนา (ทั้งที่แจกฟรีและขาย) ยังขยับตัวยากอยู่ ด้วยเหตุผลที่ทีมพัฒนา Joomla 4.0 ในโค้งสุดท้ายก่อนออกเวอร์ชั่นจริง ได้ตัดเอา jquery ออกไปไม่สนับสนุน

ยังไงก็รอไปก่อนครับ สำหรับ Joomla 3.10 น่าจะมีการสนับสนุนออกแพทซ์แก้ไขเพื่อให้เกิดความปลอดภัย ได้ใช้งานกันต่ออีกสัก 2-3 ปีแน่ๆ ใจเย็นๆ นะ ส่วนเว็บไซต์ทีทีมผมซัพพอร์ตก็ยังใช้ Joomla 3.10 ไปก่อน เนื่องจากบางหน่วยงานยังมี Services หลายๆ ตัวที่เขียนขึ้นเองยังไม่ได้อัพเดทเวอร์ชั่นของ PHP กันถ้าอัพเดทจะมีปัญหากระทบเป็นวงกว้าง ต้องค่อยๆ ทยอยแก้ให้รองรับค่อยปรับเปลี่ยนไปพร้อมกันครับ

หลังจากที่ผมได้ทยอยอัพเดทเว็บไซต์ตัวเองเป็น Joomla 3.10 ไม่กี่วันก็มีอัพเดท 3.10.1 และ 3.10.2 ตามมาเพื่อแก้ไขปัญหาด้านความปลอดภัยกันแล้ว แต่โมดูล ปลั๊กอินหลายตัวก็ไม่รองรับต้องถอนออกเพื่อให้อัพเดทได้ เรียกว่าสิ่งที่เคยใช้งานเด่นๆ หลายตัวไม่ทำงานเพราะทีมผู้พัฒนายังไม่อัพเกรดตาม ในส่วน Joomla 4.0 ก็อัพเดทตามมาติดๆ เป็น 4.0.3 แล้ว แต่ที่ผมยังไม่ไปต่อเพราะเหตุผลที่ทางโฮสท์ยังไม่อัพเกรด PHP Version เป็นสูงกว่า 7.25 นั่นเอง เท่าที่สำรวจตอนนี้ Template ที่กล้าประกาศว่ารองรับ Joomla 4.0 ยังมีน้อยมากๆ รวมทั้งพวกโดูล คอมโพเนนท์ ปลักอินทั้งหลายด้วย รอกันต่อไป

ถ้าใจร้อนก็ไปศึกษากันให้ดีก่อนเลย Joomla 4.0

สนับสนุนให้ Easyhome อยู่รับใช้ท่านตลอดไป ด้วยการคลิกแบนเนอร์ไปเยี่ยมผู้สนับสนุนของเราด้วยครับ
นโยบายความเป็นส่วนตัว Our Policy

ยินดีต้อนรับทุกท่านสู่เว็บไซต์ Easyhome in Thailand เว็บไซต์ของเรา ใช้คุกกี้ (Cookies) เพื่อให้ท่านได้รับประสบการณ์การใช้งานที่ดียิ่งขึ้น อ่านนโยบายคุ้มครองข้อมูลส่วนบุคคล (Privacy Policy) และนโยบายคุกกี้ (Cookie Policy)